summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authordweller <dweller@cabin.digital>2024-09-17 23:24:18 +0300
committerdweller <dweller@cabin.digital>2024-09-17 23:24:18 +0300
commiteea23fa7023b310e135abc1dac275625858b813b (patch)
treedf7f91a0f381f35d8706631403b1f54cfea52ea6 /CMakeLists.txt
parent68a2a3a373f01ec128221f2c7dec998bdd832a85 (diff)
seems to be working read from EEPROM
Diffstat (limited to '')
-rw-r--r--CMakeLists.txt15
1 files changed, 11 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ec8beae..9ceb9ea 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -6,7 +6,6 @@ project(eeprom2blk)
enable_language(C CXX ASM)
add_executable(eeprom2blk main.c)
-
set_source_files_properties(main.c PROPERTIES
COMPILE_FLAGS -Wall -Wextra -pedantic
C_STANDARD 90
@@ -15,11 +14,19 @@ set_source_files_properties(main.c PROPERTIES
file(MAKE_DIRECTORY ${CMAKE_CURRENT_LIST_DIR}/generated)
pico_generate_pio_header(eeprom2blk ${CMAKE_CURRENT_LIST_DIR}/ws2812.pio OUTPUT_DIR ${CMAKE_CURRENT_LIST_DIR}/generated)
-target_link_libraries(eeprom2blk pico_stdlib hardware_pio hardware_dma)
+target_include_directories(eeprom2blk PUBLIC ${CMAKE_CURRENT_LIST_DIR})
+target_link_libraries(eeprom2blk PUBLIC
+ pico_stdlib
+ hardware_pio
+ hardware_dma
+ pico_unique_id
+ tinyusb_device
+ tinyusb_board
+)
# change default stdout
-pico_enable_stdio_usb(eeprom2blk 1)
-pico_enable_stdio_uart(eeprom2blk 0)
+pico_enable_stdio_usb(eeprom2blk 0)
+pico_enable_stdio_uart(eeprom2blk 1)
# create map/bin/hex/uf2 file in addition to ELF.
pico_add_extra_outputs(eeprom2blk)